Communicate

While in your office or away, you can communicate with colleagues and clients through e-mail or with presentation graphics. You can exchange information by use of a personal digital assistant or a palmtop computer. With your ThinkPad(R) you can stay in contact without staying in your office.


Prepare a presentation

The right combination of words and images can be the deciding factor in winning a new client, lining up investors, or motivating your staff. You want to be sure everything goes right during your presentation, from connecting to an LCD projector to making sure that your computer stays on for your entire session.

The Presentation Director wizard takes you step-by-step through setting up your computer to work with a projector and a monitor, even equipment that's unfamiliar.

To start the Presentation Director, click this button:

See also information about connecting to other displays.


Transfer and synchronize data

With your ThinkPad computer and a device such as a palmtop computer or a personal digital assistant (PDA), you can synchronize your electronic calendars, address books, and other applications.

Depending on the device and the software that came with it, you can exchange information by the infrared (IR) port or by cable with the ThinkPad serial port.


Using the infrared port

Transfer and synchronize data with the infrared port

Note: Follow these steps before installing the software that came with your palmtop computer or other external device. When you are ready to begin a transfer, be sure that nothing obstructs the path between the infrared ports.

  1. Click here to configure the infrared port:

  2. Click the list arrow, click Enable, and then click OK.

  3. Install and use the software that came with your external device, following the instructions provided for the software.

Related topics

Ports

Use ports and connectors

Resolve input problems


Using the serial port

Transfer and synchronize data with the serial port

You can transfer data and synchronize files with devices that use the serial port. (View the serial port.)

Note: Follow these steps before installing the software that came with your palmtop computer or other external device.

  1. Click this button
    2. to start the infrared port configuration application.

  2. Click the list arrow, click Enable, and then click OK.

  3. Install and use the software that came with your external device, following the instructions provided for the software.

Related topics

Ports

Use ports and connectors

Resolve input problems


Connect to the Internet

Your ThinkPad computer has a built-in modem, so if you haven't accessed the Internet and the World Wide Web already, you're almost there.

Establish an account with an Internet service provider (ISP), connect your computer to a phone line, set up your modem, and you're on your way to the information highway.


Sign up with a service provider

Sign up with an Internet service provider

Depending on your ThinkPad model and the country where you purchased your computer, there are several ways to sign up with an Internet service provider (ISP). Click this button to see the online service or services that are available to you:

Signing up with an ISP usually means paying a monthly service charge. Be sure to familiarize yourself with required payments. Some ISPs offer introductory packages so that you can become familiar with the service before you commit.

Related topics

Use the built-in modem

Resolve modem problems

Search for information


Search for information

Before you can connect to the Internet and search for information, you must sign up for Internet service with an Internet service provider (ISP). If you have not already opened an Internet account, see Sign up with an Internet service provider. If you have an ISP account, follow these steps.

  1. Connect to the Internet, using your Internet Service Provider.
  2. Click the Search icon in the Web browser.
  3. To begin a search, click in the text area and type some keywords--for example, scuba diving..
  4. Click the Search button to submit your search request (it might be called Search, Seek, Find, or Go).
    5. The search utility opens a list of Web pages that contain the words you typed. Links to the Web pages are shown underlined and in blue.
  5. Click the link to the page you want to view.
  6. To return to the search results page or to begin a new search, click the Back button on your Web browser.


Connect to a LAN

Many offices have local area networks (LANs) where computers are interconnected.

LANs present unique situations for notebook computer users. This section provides important information about these situations:

  • Access the LAN

  • Install a network card

  • Connect remotely to the LAN

  • Resolve resource conflicts


Access the LAN

To access the LAN:

  1. Find or secure a physical connection point. If you cannot find one, go to step 2.

  2. Have the network administrator set up a jack, or node, on the LAN.

  3. Have the LAN administrator establish an address for the node and an account for you. The account set up for you will probably include a user ID and a password, to keep unauthorized people off the network.

  4. Once the network is ready for you and your ThinkPad computer, you have to get your computer prepared for the network. Click here to go to Install a network card .


Install a network card

You can use a Combo or an Ethernet Mini-PCI Card, or a PC Card to connect to a LAN. Some models of the ThinkPad computer have the Mini-PCI Card.

After you have the correct card for your network, you need to configure your computer to connect to the LAN. In most cases, immediately after you properly install the network PC Card, the computer informs you that new hardware has been detected and it will lead you through the configuration process.

If the configuration process does not start automatically after you have properly installed the network card, refer to the documentation that came with your network card or get technical assistance from the manufacturer of the card.

You must install and configure the proper software so that your computer will recognize the network. Speak with your network administrator about which software application you need and how to install it.

Related topics

Connect remotely to the LAN

Resolve resource conflicts

Resolve PC card problems

Get card software support


Connect remotely to the LAN

Depending on your LAN, you might be able to connect to your network if you are away from the office. If your LAN has a phone line or lines dedicated to dial-up clients, you can use a modem to establish a connection to the LAN.

Make sure that your dialing properties are set up for dial-up networking.

If the LAN does not have dial-up networking capability (many do not), you might be able to access some information and e-mail over the Internet. Check with your network administrator for details about networking over the Internet.

Related topics

Access the LAN

Install a network card

Use a PC card

Use your ThinkPad away from the office

Use the built-in modem


Resolve resource conflicts

For each OC Card you install, including a network card, your computer will need: an interrupt request level (IRQ) and a direct memory access channel (DMA). When you add a PC Card to your ThinkPad computer, you might exceed the number of IRQs or DMAs allowed in the operating system.

The ThinkPad Configuration Program tries to maintain the hardware configuration by managing the system resources automatically. In some cases, you might have to disable one device in order to use another one.

You can also resolve resource conflicts by use of the Device Manager or the IBM BIOS Setup Utility.

For information about resolving resource conflicts, go to the section dedicated to resolving system conflicts.

Related topics

Install a network card

Use a PC card

Resolve PC card problems


Built-in modem

Some models of your computer have a Mini-PCI Card modem, which enables you to send or receive data, faxes, and voice over a telephone line.

To set the built-in modem, refer to "Get an outside line."


Use the built-in modem

Some models of your computer have a Mini-PCI Card modem, which enables you to send or receive data and faxes over a telephone line. This modem uses a digital signal processor (DSP), and its software can be upgraded, allowing great flexibility. It supports ITU-T V.90 protocols with data rates of 56 Kbps.

You can use the modem only on a public-switched telephone network (PSTN). You cannot use a private branch exchange (PBX) or any other type of digital telephone extension line. If you connect the modem to a line other than PSTN, an error message appears, preventing you from using the line. If you are not sure which kind of phone line you are using, contact your telephone company.

Danger: To avoid shock hazard, do not connect the cable to or disconnect the cable from the telephone outlet on the wall during electrical storms.

To set the built-in modem, refer to "Get an outside line."

Note: Your computer might have both a modem connector (left) and an Ethernet connector (right). Be sure to connect your cable to the correct one.

Related topics

Replace the Mini-PCI Card

Enter correct dialing properties

Travel abroad

Connect while on an airplane

Connect to the Internet

Connect to your office while on the road


Use the 56-Kbps modem

To take advantage of your modem's 56-Kbps standard protocol (ITU-T V.90), you must first make sure that your Internet Service Provider (ISP) supports the protocol.

Find out which 56-Kbps modem protocol your ISP uses.

If your ISP supports the 56-Kbps standard protocol (ITU-T V.90), your modem uses the same 56-Kbps protocol. Your modem and your ISP must support the same 56-Kbps protocol: otherwise, your maximum connection speed will be limited to V.34 technology.

Significantly higher Internet modem connection speeds, up to 56 Kbps, require all-digital transmission connection from your ISP to the line card in the central office to which your phone line is connected. Failure of the modem to operate at high speed should not be reported as a fault, unless ordinary voice telephone calls are substandard.

In the U.S., current FCC regulations limit the maximum speed for downstream communication to 56 Kbps. Even though your modem contains 56-Kbps technology, the connect rate in the receive direction might be significantly less than 56 Kbps.

Currently, the 56-Kbps capability is in the receive direction only (from the ISP to your local modem). The transmit or send direction (from your local modem to the ISP) uses V.34 technology.

Note: 56-Kbps transfer rates are not available in all locations. Ask your ISP whether your area is capable of 56-Kbps transfer rate.


Use the telephony features

The built-in modem has the following telephony features:

Industry standard modem support up to 56 Kbps:

Data protocols

  • Bell 103 (300 bps)

  • Bell 212A (1200 bps)

  • V.21 (300 bps)

  • V22bis (2400 bps)

  • V.34bis (33600, 31200 bps)

  • V.34 (28800, 26400,24000,21600,19200,16800,14400,12000,9600,7200,4800 bps)

  • V.90 (downstream only)

Error correction protocols

  • MNP2-4 (Microcom error correction)

  • V.42 (error-correcting procedures for DCEs using asynchronous automatic dialing and control)

Data compression protocols

  • V.42bis (DCE data compression)

  • MNP5 (Microcom data compression)

Miscellaneous protocols

  • V.8 (startup sequence)

  • V.90 (video phone)

Industry standard fax support up to 14.4 Kbps:

Fax protocols

  • V.21 Ch 2 (300-bps fax)

  • V.17 (up to 14.4-Kbps fax)

  • V.29 (9600-bps fax)

  • V.27ter (4800-bps fax)

Computer telephony function support:

  • DTMF and pulse dialing

  • Detecting DTMF digits received from the phone line

  • Call progress monitoring

  • An auto-dialing feature

  • Telephony API (TAPI) support through Windows 98 and Window 95


Modem commands

This section provides information on the AT modem commands, in case you need to operate your modem from terminal software.

Running commands

Your modem is in command mode, ready to receive and run AT commands, as soon as you turn on the computer. It remains in command mode until it connects with a remote modem. You can send commands to the modem from an attached terminal or a PC running a communication program.

The modem is designed to operate at common DTE speeds ranging from 115.2 Kbps (or 57.6 Kbps) to 300 Kbps. All commands and data must be issued to the modem at one of the valid DTE speeds.

Command format

All commands except A/ must begin with the prefix AT, followed by the command letter, and must end with the Enter key. Spaces are allowed in the command string to increase readability, but the modem ignores them while executing a command. All commands may be typed in either uppercase or lowercase, but not in mixed case. A command issued without a parameter is considered to have parameter "0".

Examples:

ATL[Enter] causes your modem to lower the volume from its speaker.

ATH1[Enter] causes your modem to go off hook.

AT commands

Command

Function

+++

Escape sequence:

Leave data mode and enter online command mode.

A/

Repeat last command:

Repeat the preceding command.

Note: Do not precede with AT or follow with Enter.

A

Answer command:

Answer an incoming call.

Bn

Communication standard setting:

Determine the standard.

B0: Select ITU/CCITT V.22 mode @ 1200 bps.

B1: Select BELL 212A @ 1200 bps (default).

B2: Deselect V23 reverse channel (same as B3).

B3: Deselect V23 reverse channel (same as B2).

B15: Select ITU/CCITT V.21mode @ 300 bps.

B16: Select BELL 103J mode @ 300 bps.

Cn

Carrier control:

C0: Transmit carrier always off.

C1: Normal transmit carrier switching.

Dsn

Dial a telephone number n (n=0-9, A-D, #, or *) automatically. You can assign the following values of s:

L Redial the last number dialed.

P Specify pulse dial.

T Specify tone dial (default).

W Wait for a second dial tone.

, Pause.

@ Wait for 5 seconds of silence.

! Specify flash.

; Return to command mode after dialing.

$ Detect a bong tone.

DS=n

Dial command:

Dial one of four telephone numbers (n=0-3) stored in the nonvolatile memory of the modem.

En

Echo command:

E0: Disable echo to the computer.

E1: Enable echo to the computer (default).

Fn

Online data character echo command:

Determine whether the modem will echo data from the DTE.

F0: Online data character echo enabled (this is not supported).

F1: Online data character echo disabled.

Hn

Hook control:

Control on-hook/off-hook.

H0: Modem goes on-hook (default).

H1: Modem goes off-hook.

I

Request ID information:

Display product information about the modem.

I0: Specify the firmware and device ID.

I1: Specify the checksum code.

I2: Start the ROM test and verify the checksum.

I3: Specify the firmware and device ID (same as I0).

I4: Specify the firmware version for the data pump.

I5: Specify the code version, board ID, country ID, and subsystem vendor ID in hexadecimal.

I6-8: Return OK for compatibility.

I9: Specify the country ID in English.

I11: Display connection information.

L

Set the speaker volume:

L0: Low volume.

L1: Low volume.

L2: Medium volume (default).

L3: High volume.

M

Control the speaker mode.

M0: Turn the speaker off.

M1: Turn the speaker on until the modem detects the carrier signal (default).

M2: Keep the speaker on when the modem is off the hook.

M3: Keep the speaker on until the carrier is detected, except when dialing.

N

Modulation handshake: Control whether the local modem performs a negotiated handshake.

N0: Disable auto mode, with the modem handshake speed specified by S37.

N1: Enable auto mode, with the modem handshake speed specified by S37 (default).

O

Return to online data mode.

O0: Return to data mode.

O1: Start an equalizer retain, and return to data mode.

O3: Start a rate renegotiation, and return to data mode.

P

Select pulse dialing.

Q

Turn the result code on or off.

Q0: Enable the result codes (default).

Q1: Disable the result codes.

Sn

Control the S register.

Sn?: Read the S register n, where n=0-110.

Sn=r: Set the S register n to value r, where n=0-110, r=0-255.

T

Select tone dialing.

V

DCE response format:

Control the format of the result code.

V0: Display the result code as digits.

V1: Display the result code as text (default).

W

Result code options:

W0: The CONNECT result code reports the DTE receive speed. Disable the protocol result codes.

W1: The CONNECT result code reports the DTE receive speed. Enable the protocol result codes.

W2: The CONNECT result code reports the DCE receive speed. Enable the protocol result codes (default).

X

Select result code and monitor call progress:

Control the tone detection option used in the dialing process.

Extended Dial Busy

result tone tone

code detect detect

X0 Disable Disable Disable

X1 Enable Disable Disable

X2 Enable Enable Disable

X3 Enable Disable Enable

X4 Enable Enable Enable(default)

X5 Enable Enable Enable

X6 Enable Enable Enable

X7 Disable Enable Enable

Y

Keep long space disconnect disabled.

Y0: Disable long space disconnect (default).

Y1: Enable long space disconnect (not supported).

Z

Reset and recall the stored profile.

Extended AT commands

Command

Function

&B

V.32 auto-retrain:

This modem always auto-retrains.

&B0: Disable V.32 auto-retrain (not supported).

&B1: Enable V.32 auto-retrain (default).

&C

Data carrier detect (DCD) control:

&C0: Specify that carrier detect is always to be on.

&C1: Turn on the carrier detect when the remote carrier is present (default).

&D

Data terminal ready (DTR):

&D0: Ignore the DTR signal.

&D1: Return the modem to command mode after a DTR toggle.

&D2: Hang up the modem, and return to command mode after a DTR toggle (default).

&D3: Reset the modem after a DTR toggle.

&F

Local factory settings:

Load the factory default configuration.

&G

V.22bis guard tone control:

Determine which guard tone to transmit while transmitting in the high band.

&G0: Disable the guard tone (default).

&G1: Enable a 550-Hz guard tone.

&G2: Enable a 1800-Hz guard tone.

&J

Auxiliary relay option:

&J0: The auxiliary relay is never closed (default).

&J1: Not supported.

&K

Local flow control selection:

&K0: Disable flow control.

&K1: Reserved.

&K2: Reserved.

&K3: Enable RTS/CTS (hardware) flow control (default).

&K4: Enable XON/XOFF flow control.

&M

Asynchronous communications mode:

&M0: Asynchronous mode (default).

&M1: Reserved.

&M2: Reserved.

&M3: Reserved.

&M4: Reserved.

&Pn

Pulse dial make-to-break ratio selection (applies only in Japan):

&P0: 39/61 make/break ratio, 10PPS.

&P1: 33/67 make/break ratio, 10PPS (default).

&P2: 33/67 make/break ratio, 20PPS.

&Q

Asynchronous communication mode:

&Q0: Asynchronous mode, buffered. (same as \N0).

&Q5: Error control mode, buffered default. (same as \N3).

&Q6: Asynchronous mode, buffered (same as \N0).

&Q8: MNP error control mode. If an MNP error control protocol is not established, the modem will fall back according to the current user setting in S36.

&Q9: V.42 or MNP error control mode. If neither error control protocol is established, the modem will fall back according to the current user setting in S36.

&S

Data set ready (DSR) option:

This command selects the DSR action.

&S0: DSR always ON (default).

&S1: DSR comes on when a connection is established, and goes off when the connection ends.

&T

Self-test commands:

Do diagnostic tests on the modem.

&T0: Abort. Stop any test in progress.

&T1: Local analog loop.

&T3: Local digital loopback test.

&T6: Remote digital loopback test.

&V

View the active configuration:

This command is used to display the active profiles.

&W

Store current configuration:

Store certain command options and S-register values except S3, S4, S5.

&Y

Select the stored profile for hard reset (for compatibility with applications that issue the &Y0 command):

&Y0: Select stored profile 0 on power-up.

&Y1: Error.

&Z

Store the telephone number:

Store up to 4 digits in a dialing string.

\A

Select the maximum MNP block size:

\A0: 64 characters.

\A1: 128 characters.

\A2: 192 characters.

\A3: 256 characters.

\B

Transmit break to remote:

\Bn: Break length in 100ms units (n=1-9, default: 3).

\G

Control the flow of the modem port:

\G0: Modem is to process XON/XOFF flow control characters locally (default).

\G1: Modem is to process XON/XOFF flow control characters.

\J

Adjust bit/s rate control:

\J0: Buffer mode. Error control selected by \Nn command (default).

\J1: Force the maximum DCE rate to the DTE rate.

\K

Send break control:

[a] If the modem receives a break from the DTE while the modem is operating in data transfer mode:

\K0: Enter online command mode. Don't send a break to the remote modem.

\K1: Clear the data buffers and send a break to the remote modem.

\K2: Same as \K0.

\K3: Send a break to the remote modem immediately.

\K4: Same as \K0.

\K5: Send a break to the remote modem in sequence with transmitted data (default).

[b] If the modem is in the online command state during a data connection, and \B is received to send a break to the remote modem:

\K0: Clear data buffers and send a break to the remote modem.

\K1: Same as \K0.

\K2: Send a break to the remote modem immediately.

\K3: Same as \K2.

\K4: Send a break to the remote modem in sequence with data.

\K5: Same as \K4 (default).

[c] If a break is received from a remote modem during a connection:

\K0: Clear the data buffers and send a break to the DTE.

\K1: Same as \K0.

\K2: Send a break to the remote modem immediately.

\K3: Same as \K1.

\K4: Send a break in sequence with received data to DTE.

\K5: Same as \K4 (default).

\N

Select error control mode:

\N0: Buffer mode. No error control (same as &Q6).

\N1: Direct mode.

\N2: MNP or disconnect mode.

\N3: V.42, MNP, or buffer (default).

\N4: V.42 or disconnect.

\N5: V.42, MNP, or buffer (same as \N3).

\N7: V.42, MNP, or buffer (same as \N3).

\Q

Select local flow control:

\Q0: Disable flow control. (same as &K0).

\Q1: XON/XOFF software control. (same as &K4).

\Q2: CTS-only flow control. This is not supported, and the response is error.

\Q3: RTS/CTS to DTE (default). (same as &K3).

\R

Ring indicator off after answer:

\R0: The ring indicator signal goes off when the telephone is answered.

\T

Inactivity timer:

\T0: Inactivity timer disabled (default).

\Tn: Inactivity timer, n minutes. (n=1-255)

\V

Protocol result code:

\V0: Disable the protocol result code appended to the DCE speed.

\V1: Enable the protocol result code appended to the DCE speed (default).

\V2: Same as \V1.

\X

XON/XOFF passthrough:

\X0: Specify that the modem is to process XON/XOFF flow control characters locally (default).

\X1: Specify that the modem is to pass XON/XOFF flow control characters.

%B

View numbers in the blacklist:

Displays the numbers for which the last call attempted in the past 2 hours failed.

%C

Data compression control:

%C0: V.42bis/MNP5 disabled. No data compression.

%C1: V.42bis/MNP5 enabled. Data compression enabled (default).

%E

Automatic rate change:

%E0: Disable fall-back and fall-forward.

%E1: Enable fall-back, but disable fall-forward.

%E2: Enable fall-back and fall-forward (default).

-C

Data calling tone:

-C0: Disabled (default).

-C1: Enabled.

-V90

Enable or disable the V.90 setting:

-V90=0: Disable V.90.

-V90=1: Enable V.90 auto rate (default).

-V90=n: Control the downstream rate (2-23).

-V90=?: Show the range of n.

-V90?: Show the current value.


Modem result codes

The following table lists the basic codes that the modem sends to your computer in response to the commands you enter. They are called result codes.

Numeric | Result code | Description
0 | OK | The command has been run.
1 | Connect | The modem is connected to the line.
2 | Ring | A ring signal has been detected.
3 | No carrier | The modem lost the carrier signal, or does not detect the carrier signal, or does not detect the answer tone.
4 | Error | Invalid command.
5 | Connect 1200EC | Connection at 1200 bit/s.
6 | No dial tone | No dial is tone detected.
7 | Busy | Busy signal is detected.
8 | No answer | The remote end never answered.
10 | Connect 2400 EC | Connection at 2400 bit/s.
11 | Connect 4800 EC | Connection at 4800 bit/s.
12 | Connect 9600 EC | Connection at 9600 bit/s.
13 | Connect 14400 EC | Connection at 14400 bit/s.
14 | Connect 19200 EC | Connection at 19200 bit/s.
18 | Connect 57600 EC | Connection at 57600 bit/s (DTE rate).
24 | Connect 7200 EC | Connection at 7200 bit/s.
25 | Connect 12000 EC | Connection at 12000 bit/s.
28 | Connect 38400 EC | Connection at 38400 bit/s (DTE rate).
40 | Connect 300 EC | Connection at 300 bit/s.
55 | Connect 21600 EC | Connection at 21600 bit/s.
56 | Connect 24000 EC | Connection at 24000 bit/s.
57 | Connect 26400 EC | Connection at 26400 bit/s.
58 | Connect 28800 EC | Connection at 28800 bit/s.
59 | Connect 31200 EC | Connection at 31200 bit/s.
60 | Connect 33600 EC | Connection at 33600 bit/s.
70 | Connect 32000 EC | Connection at 32000 bit/s (K56flex mode or V.90).
71 | Connect 34000 EC | Connection at 34000 bit/s (K56flex mode).
72 | Connect 36000 EC | Connection at 36000 bit/s (K56flex mode or V.90).
73 | Connect 38000 EC | Connection at 38000 bit/s (K56flex mode).
74 | Connect 40000 EC | Connection at 40000 bit/s (K56flex mode or V.90).
75 | Connect 42000 EC | Connection at 42000 bit/s (K56flex mode).
76 | Connect 44000 EC | Connection at 44000 bit/s (K56flex mode or V.90).
77 | Connect 46000 EC | Connection at 46000 bit/s (K56flex mode).
78 | Connect 48000 EC | Connection at 48000 bit/s (K56flex mode or V.90).
79 | Connect 50000 EC | Connection at 50000 bit/s (K56flex mode).
80 | Connect 52000 EC | Connection at 52000 bit/s (K56flex mode or V.90).
81 | Connect 54000 EC | Connection at 54000 bit/s (K56flex mode).
82 | Connect 56000 EC | Connection at 56000 bit/s (K56flex mode or V.90).
86 | Connect 16800 EC | Connection at 16800 bit/s.
87 | Connect 115200 EC | Connection at 115200 bit/s (DTE rate).
88 | Delayed | Delay is in effect for the dialed number.
89 | Blacklisted | The dialed number is blacklisted.
90 | Blacklist full | The blacklist is full.
100 | Connect 28000 EC | Connection at 28000 bit/s (V.90 mode).
101 | Connect 29333 EC | Connection at 29333 bit/s (V.90 mode).
102 | Connect 30666 EC | Connection at 30666 bit/s (V.90 mode).
103 | Connect 33333 EC | Connection at 33333 bit/s (V.90 mode).
104 | Connect 34666 EC | Connection at 34666 bit/s (V.90 mode).
105 | Connect 37333 EC | Connection at 37333 bit/s (V.90 mode).
106 | Connect 38666 EC | Connection at 38666 bit/s (V.90 mode).
107 | Connect 41333 EC | Connection at 41333 bit/s (V.90 mode).
108 | Connect 42666 EC | Connection at 42666 bit/s (V.90 mode).
109 | Connect 45333 EC | Connection at 45333 bit/s (V.90 mode).
110 | Connect 46666 EC | Connection at 46666 bit/s (V.90 mode).
111 | Connect 49333 EC | Connection at 49333 bit/s (V.90 mode).
112 | Connect 50666 EC | Connection at 50666 bit/s (V.90 mode).
113 | Connect 53333 EC | Connection at 53333 bit/s (V.90 mode).
114 | Connect 54666 EC | Connection at 54666 bit/s (V.90 mode).


S registers

S registers are information storage areas inside the modem. The AT command set uses the S registers to configure modem options. Some S registers have default settings. These are usually adequate for normal modem operations. In special circumstances, however, you may need to change some defaults.

To read or change the value of an S register, begin the command with the letters AT.

To read the value of an S register, use the command ATSr? where r is a register number 0-110. For example, to read the value of S register 0, type ATS0? and press Enter.

To change the value of an S register, use the command ATSr=n where r is a register number 0-110, and n is the new value you want to assign. For example, to change the value of S register from 0 to 20 rings, type ATS0=20 and press Enter.

The following table lists the S registers:

Register

Function

Register value

S0

Auto-answer ring number

0-255 rings

S1

Ring counter

0-255 rings

S2

AT escape character (user-defined)

0-127 ASCII

S3

Command line termination character (user-defined)

0-127 ASCII

S4

Response formatting character (user-defined)

0-127 ASCII

S5

Command line editing character (user-defined)

0-127 ASCII

S6

Wait before dialing

2-65 seconds

S7

Connection completion timeout

1-255 seconds

S8

Comma dial modifier time

0-65 seconds

S10

Automatic disconnect delay

1-254 10ths of a seconds

S11

DTMF dialing speed

50-150 milliseconds

S12

Escape guard time

0-255 50ths of a second

S14

Status of general bitmapped options

Only bits 2 and bit 6 are used.

Bit 2: Result codes (Vn)

    0=Numeric (V0)

    1=Verbal (V1)

Bit 6: Pulse dial PPS selection (&Pn)

    0=10 PPS (&p0, &p1)

    1=20 PPS (&p2)

S21

Status of V.24 and general bitmapped options

Only bits 3, 4, and 5 are used.

Bits 3 and 4: DTR behavior (&Dn)

    0=&D0 selected

    1=&D1 selected

    2=&D2 selected

    3=&D3 selected

Bit 5: DCD behavior (&Cn)

    0=&C0 selected

    1=&C1 selected

S22

Status of results bitmapped options

Only bits 4, 5, and 6 are used.

Bits 4-5: result codes (Xn)

    0=X0 selected

    4=X4 selected

    5=X5 selected

    6=X6 selected

    7=X7 selected

S24

Timer to control sleep mode

0, 5-65 seconds

S28

Enable or disable of V.34 modulation

0=Disabled

1=Enabled

S30

Inactivity timer

0-255 minutes

S32

Synthetic ring volume

0-255

S33

Synthetic ring frequency

0-5

S35

Data calling tone

0=Disabled

1=Enabled

S36

Negotiation fallback

See S48

S37

Dial line rate

0=Auto rate

1=Reserved

2=1200/75 bps (V.23)

3=300 bps

4=Reserved

5=1200 bps

6=2400 bps

7=4800 bps

8=7200 bps

9=9600 bps

10=12000 bps

11=14400 bps

12=16800 bps

13=19200 bps

14=21600 bps

15=24000 bps

16=26400 bps

17=28800 bps

18=31200 bps

19=33600 bps

S38

K56flex downstream rate

0=Disable K56flex

1=Automatic rate selection

2=32 kbps

3=34 kbps

4=36 kbps

5=38 kbps

6=40 kbps

7=42 kbps

8=44 kbps

9=46 kbps

10=48 kbps

11=50 kbps

12=52 kbps

13=54 kbps

14=56 kbps

S42

Auto rate

This command is used for testing and debugging only.

    0=Disabled

    1=Enabled

S43

Auto mode

This command is used for testing and debugging only.

    0=Disabled

    1=Enabled

S48

LAPM error control and feature negotiation

This function is set by the combination of the value in S48 and S36.

S48=7 Enabled

S36=0,2 LAPM or hangup

S36=1,3 LAPM or async

S36=4,6 LAPM, MNP or hangup

S36=5,7 LAPM, MNP or async

S47=128

S48=128 Disabled

S36=0,2 do not use

S36=1,3 async

S36=4,6 MNP or hangup

S36=5,7 MNP or async

S89

Timer to control sleep mode

0, 5-65 seconds

S90

Read-only local phone

0=on-hook

1=off-hook

S91

Line transmit level

6-15 dB

S108

Network coded type

22=mu-Law

33=A-Law

7 =V.8 information. Or choose on the basis of the country ID.


Notices

(C) Copyright International Business Machine Corporation 2000. All rights reserved. Note to U.S. Government Users--Documentation related to restricted rights--Use, duplication, or disclosure is subject to restrictions set forth in GSA ADP Schedule Contract with IBM Corp.

References in this publication to IBM products, programs, or services do not imply that IBM intends to make these available in all countries in which IBM operates. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any of the intellectual property rights of IBM may be used instead of the IBM product, program, or service. The evaluation and verification of operation in conjunction with other products, except those expressly designated by IBM, are the responsibility of the user.

IBM may have patents or pending patent applications covering subject matter in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to the IBM Director of Licensing, IBM Corporation, North Castle Drive, Armonk, NY 10504-1784, U.S.A.

Year 2000 readiness and instructions

This is a Year 2000 Readiness Disclosure.

A product is Year 2000 Ready if the product, when used in accordance with its associated documentation, is capable of correctly processing, providing and/or receiving date data within and between the 20th and 21st centuries, provided all other products (for example, software, hardware, and firmware) used with the product properly exchange date data with it.

This IBM PC hardware product has been designed to process four-digit date information correctly within and between the 20th and 21st centuries. If your IBM computer is on when the century changes, you should turn it off and then back on again once, or restart the operating system, to ensure that the internal clock resets itself for the new century.

This IBM PC product cannot prevent errors that might occur if software you use or exchange data with is not ready for the Year 2000. IBM software that comes with this product is Year 2000 Ready. However, software from other companies might come with this IBM PC product. IBM cannot take responsibility for the readiness of that software. You should contact the software developers directly if you wish to verify readiness, understand limitations, or look for any software updates.

To learn more about IBM PC products and the Year 2000, visit our Web site at http://www.pc.ibm.com/year2000. The information and tools there can help you with your Year 2000 transition plan, especially if you have multiple IBM PCs. IBM

encourages you to check periodically for updated information.

Electronic emission notices

Federal Communications Commission (FCC) Statement

ThinkPad T20, model number 2647, 2648, or 2649

This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of the following measures:

  • Reorient or relocate the receiving antenna.

  • Increase the separation between the equipment and receiver.

  • Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.

  • Consult an IBM authorized dealer or service representative for help.

Properly shielded and grounded cables and connectors must be used in order to meet FCC emission limits. Proper cables and connectors are available from IBM authorized dealers. IBM is not responsible for any radio or television interference caused by unauthorized changes or modifications to this equipment. Unauthorized changes or modifications could void the user's authority to operate the equipment.

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) this device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause undesired operation.

Responsible Party:

International Business Machines Corporation

New Orchard Road

Armonk, NY 10504

Telephone 1-919-543-2193

Industry Canada Class B Emission Compliance Statement

This Class B digital apparatus complies with Canadian ICES-003.

Avis de conformite a la re glementation d'Industrie Canada

Cet appareil numerique de la classe B est conform a la norme NMB-003 du Canada.

European Community Directive Conformance Statement

This product is in conformity with the protection requirements of EU Council Directive 89/336/EEC on the approximation of the laws of the Member States relating to electro-magnetic compatibility. IBM cannot accept responsibility for any failure to satisfy the protection requirements resulting from a non-recommended modification of the product, including the fitting of non-IBM option cards.

A declaration of Conformity with the requirements of the Directive has been signed by IBM United Kingdom Limited, PO BOX 30 Spango Valley Greenock Scotland PA160AH.

This product satisfies the Class B limits of EN 55022.

Telecommunication notice

Federal Communications Commission (FCC) and telephone company requirements

  1. This device complies with Part 68 of the FCC rules. A label is affixed to the device that contains, among other things, the FCC registration number, USOC, and Ringer Equivalency Number (REN) for this equipment. If these numbers are requested, provide this information to your telephone company.

    Note:If the device is an internal modem, a second FCC registration label is also provided. You may attach the label to the exterior of the computer in which you install the IBM modem, or you may attach the label to the external DAA, if you have one. Place the label in a location that is easily accessible, should you need to provide the label information to the telephone company.

  2. The REN is useful to determine the quantity of devices you may connect to your telephone line and still have those devices ring when your number is called. In most, but not all areas, the sum of the RENs of all devices should not exceed five (5). To be certain of the number of devices you may connect to your line, as determined by the REN, you should call your local telephone company to determine the maximum REN for your calling area.

  3. If the device causes harm to the telephone network, the telephone company may discontinue your service temporarily. If possible, they will notify you in advance; if advance notice is not practical, you will be notified as soon as possible. You will be advised of your right to file a complaint with the FCC.

  4. Your telephone company may make changes in its facilities, equipment, operations, or procedures that could affect the proper operation of your equipment. If they do, you will be given advance notice to give you an opportunity to maintain uninterrupted service.

  5. If you experience trouble with this product, contact your authorized reseller, or call IBM. In the United States, call IBM at 1-800-772-2227. In Canada, call IBM at 1-800-565-3344. You may be required to present proof of purchase.

    The telephone company may ask you to disconnect the device from the network until the problem has been corrected, or until you are sure the device is not malfunctioning.

  6. No customer repairs are possible to the device. If you experience trouble with the device, contact your Authorized Reseller or see the Diagnostics section of this manual for information.

  7. This device may not be used on coin service provided by the telephone company. Connection to party lines is subject to state tariffs. Contact your state public utility commission or corporation commission for information.

  8. When ordering network interface (NI) service from the local Exchange Carrier, specify service arrangement USOC RJ11C.

Canadian Department of Communications certification label

NOTICE: The Industry Canada label identifies certified equipment. This certification means that the equipment meets telecommunications network protective, operational and safety requirements as prescribed in the appropriate Terminal Equipment Technical Requirements documents. The Department does not guarantee the equipment will operate to the user's satisfaction.

Before installing this equipment, users should ensure that it is permissible to be connected to the facilities of the local telecommunications company. The equipment must also be installed using an acceptable method of connection. The customer should be aware that compliance with the above conditions may not prevent degradation of service in some situations. Repairs to certified equipment should be coordinated by a representative designated by the supplier. Any repairs or alterations made by the user to this equipment, or equipment malfunctions, may give the telecommunications

company cause to request the user to disconnect the equipment.

Users should ensure for their own protection that the electrical ground connections of the power utility, telephone lines, and internal metallic water pipe system, if present, are connected together. This precaution may be particularly important in rural areas.

Caution: Users should not attempt to make such connections themselves, but should contact the appropriate electric

inspection authority, or electrician, as appropriate.

NOTICE: The Ringer Equivalence Number (REN) assigned to each terminal device provides an indication of the maximum number of terminals allowed to be connected to a telephone interface. The termination on an interface may consist of any combination of devices subject only to the requirement that the sum of the Ringer Equivalence Numbers of all the devices does not exceed 5.

etiquette d'homologation du ministere des Communications du Canada

AVIS : L'etiquette d'Industrie Canada identifie le materiel homologue. Cette etiquette certifie

que le materiel est conforme aux normes de protection, d'exploitation et de securite des reseaux de

telecommunications, comme le prescrivent les documents concernant les exigences techniques relatives au materiel terminal. Le ministere n'assure toutefois pas que le materiel fonctionnera a la satisfaction de

l'utilisateur.

Avant d'installer ce materiel, l'utilisateur doit s'assurer qu'il est permis de le raccorder aux installations de l'entreprise locale de telecommunications. Le materiel doit egalement etre installe en suivant une methode acceptee de raccordement. L'abonne ne doit pas oublier qu'il est possible que la conformite aux conditions enoncees ci-dessus n'empeche pas la degradation du service dans certaines situations.

Les reparations de materiel homologue doivent etre coordonnees par un representant designe par le fournisseur. L'entreprise de telecommunications peut demander a l'utilisateur de debrancher un appareil a la suite de reparations ou de modifications effectuees par l'utilisateur ou a cause de mauvais fonctionnement.

Pour sa propre protection, l'utilisateur doit s'assurer que tous les fils de mise a la terre de la source d'energie electrique, des lignes telephoniques et des canalisations d'eau metalliques, s'il y en a, sont raccordes ensemble. Cette precaution est particulierement importante dans les regions rurales.

Avertissement : L'utilisateur ne doit pas tenter de faire ces raccordements lui-meme; il doit avoir recours a un service d'inspection des installations electriques ou a un electricien, selon le cas.

AVIS : L'indice d'equivalence de la sonnerie (IES) assigne a chaque dispositif terminal indique le nombre maximal de terminaux qui peuvent etre raccordes a une interface. La terminaison d'une interface telephonique peut consister en une combinaison de quelques dispositifs, a la seule condition que la somme d'indices d'equivalence de la sonnerie de tous les dispositifs n'excede pas 5.

Product notice requirements

The following notice applies to machines equipped with both a DVD and a TV-out function:

This product incorporates copyright protection technology that is protected by method claims of U.S. patent numbers 4631603, 4577216, 4819098, 4907093, and other intellectual property rights owned by Macrovision Corporation and other rights owners. Use of this copyright protection technology must be authorized by Macrovision Corporation and is intended for home and other limited viewing use only, unless otherwise authorized by Macrovision Corporation. Reverse engineering or disassembly is prohibited.

Notice for Australia

The following notice applies when using the telephony functions:

WARNING:

FOR SAFETY REASONS, ONLY CONNECT EQUIPMENT WITH A TELECOMMUNICATIONS COMPLIANCE LABEL. THIS INCLUDES CUSTOMER EQUIPMENT PREVIOUSLY LABELLED PERMITTED OR CERTIFIED.

Notice for Users in New Zealand

The modem in this ThinkPad is set up for Tone Dialing. Users should only select Pulse Dialing if they are connecting to the Telecom NZ network via a PBX or other systems which requires Pulse Dialing. Pulse Dialing is required only for a small number of obsolescent PBX or similar systems.

The grant of a Telepermit for any item of terminal equipment indicates only that Telecom has accepted that the item complies with minimum conditions for connection to its network. It indicates no endorsement of the product by Telecom, nor does it provide any sort of warranty. Above all, it provides no assurance that any item will work correctly in all respects with another item of Telepermitted equipment of a different make or model, nor does it imply that any product is compatible with all of Telecom's network services.

This equipment is not capable, under all operating conditions, of correct operation at the higher speeds for which it is designed. Telecom will accept no responsibility should difficulties arise in such circumstances.

This device is equipped with pulse dialling while the Telecom standard is DTMF tone dialling. There is no guarantee that Telecom lines will always continue to support pulse dialling.

Use of pulse dialling, when this equipment is connected to the same line as other equipment, may give rise to bell tinkle or noise and may also cause a false answer condition. Should such problems occur, the user should NOT contact the Telecom Faults Service.

This equipment shall not be set to make automatic calls to the Telecom '111' Emergency Service.

This equipment should not be used under any circumstances which may constitute a nuisance to other Telecom customers.

Notice for European Union countries

The equipment described here has been approved in accordance with Council Decision 98/482/EC for pan-European single-terminal connection to the Public Switched Telephone Network (PSTN). However, because of differences between the individual PSTNs provided in different countries, the approval does not, of itself, give an unconditional assurance that the equipment will operate successfully on every PSTN network termination point. In the event of problems, you should contact your equipment supplier first. The modem integrated in this equipment is designed to work on the following country or regional networks: Austria, Belgium, Denmark, France, Finland, Germany, Greece, Iceland, Italy, Luxembourg, Netherlands, Norway, Portugal, Spain, Sweden, Switzerland, Republic of Ireland, United Kingdom. Operation in pulse dialing mode is supported only for PBXs. To operate with the networks listed above, the modem should be set as explained in the chapter headed "Use the built-in modem" in the online user's guide.

For Spain: A change in the polarity of the dc voltage can cause the connection to be broken.

Trademarks


Safety information

Important safety instructions

Danger: Electric current from power, telephone, and communication cables is hazardous. To avoid shock hazard, connect and disconnect cables as shown below when installing, moving, or opening the covers of this product or attached devices. If a 3-pin power cord is provided with this products, it must be used with a properly grounded outlet.

Danger: Reduce the risk of fire and electric shock by always following basic safety precautions, including the following:

  • Do not use your computer in or near water.

  • During electrical storms:

  • Do not use your computer with the telephone cable connection.

  • Do not connect the cable to or disconnect it from the telephone outlet on the wall.

Danger: If the rechargeable battery pack is incorrectly replaced, there is danger of an explosion. The battery pack contains a small amount of harmful substances. To avoid possible injury:

  • Replace only with a battery of the type recommended by IBM.

  • Keep the battery pack away from fire.

  • Do not expose it to water or rain.

  • Do not attempt to disassemble it.

  • Do not short-circuit it.

  • Keep it away from children.

Do not put the battery pack in trash that is disposed of in landfills. When disposing of the battery, comply with local ordinances or regulations and your company's safety procedures. In the United States, call IBM at 1-800-IBM-4333 for information on disposal.

Danger: There is danger of an explosion if the backup battery is incorrectly replaced.

The lithium battery (IBM P/N 02K6572 UL--recognized component [file no. MH12210]) contains lithium and can explode if it is not properly handled or disposed of.

Replace only with a battery of the same type.

To avoid possible injury or death, do not: (1) throw or immerse the battery into water, (2) allow it to heat to more than 100 deg C (212 deg F), or (3) attempt to repair or disassemble it. Dispose of it as required by local ordinances or regulations and your company's safety standards.

Danger: Follow the instruction, below when installing or reconfiguring the Mini PCI option.

To avoid shock hazard, disconnect all the cables and the ac adapter when you install the Mini PCI option or open the covers of the system or attached devices. Electrical current from power, telephone, and communication cables is hazardous.

CAUTION: When you have added or upgraded a Mini PCI Card or a memory card, do not use your computer until you have closed the cover. Never use the computer when the cover is open.

Remove the main battery pack of the computer also. The certain circuit of the system still exists even if the power seems to be off. Do not forget to remove the ac adapter and the battery pack.

CAUTION: The fluorescent lamp in the liquid crystal display (LCD) contains mercury. Do not put it in trash that is disposed of in landfills. Dispose of it as required by local ordinances or regulations.

The LCD is made of glass, and rough handling or dropping the computer can cause the LCD to break. If the LCD breaks and the internal fluid gets into your eyes or on your hands, immediately wash the affected areas with water for at least 15 minutes; if any symptoms are present after washing, get medical care.

CAUTION: To reduce the risk of fire, use only No. 26 AWG or larger (thicker) telephone cable.

Laser compliance statement

The CD-ROM or DVD drive that can be installed in the IBM ThinkPad computer is a laser product. The drive's classification label (shown below) is on the surface of the drive.

CLASS 1 LASER PRODUCT

LASER KLASSE 1

The drive is certified by the manufacturer to comply with the requirements of the Department of Health and Human Services 21 Code of Federal Regulations (DHHS 21 CFR) Subchapter J for Class I laser products at the date of manufacture.

In other countries, the drive is certified to conform to the requirements of EN60825.

Danger:

Do not open the CD-ROM or DVD drive unit; no user adjustments or serviceable parts are inside.

Use of controls, adjustments, or the performance of procedures other than those specified might result in hazardous radiation exposure.

Class 1 laser products are not considered hazardous. The design of the laser system and the CD-ROM or DVD-ROM drive ensures that there is no exposure to laser radiation above a Class 1 level during normal operation, user maintenance, or servicing.

Some drives contain an embedded Class 3A laser diode. Note this warning:

Danger: Emits visible and invisible laser radiation when open. Avoid direct eye exposure. Do not stare into the beam or view it directly with optical instruments.

Save these instructions.


Trademark notices

The following are trademarks of the IBM Corporation in the United States or other countries or both:

IBM

Asset ID

EtherJet

HelpCenter

HelpWare

LANClient Control Manager

Netfinity

OS/2

ThinkPad

TrackPoint

Wake on LAN

Lotus, WordPro, Freelance Graphics, and 1-2-3 are registered trademarks of Lotus Development Corporation.

Intel, LANDesk, and Pentium are trademarks of Intel Corporation in the United States and/or other countries.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States and/or other countries.

Other company, product, and service names may be trademarks or service marks of others.


Welcome

Welcome to the

ThinkPad Assistant

Your powerful ThinkPad(R) computer is loaded with

features and applications.

Use it to do anything, anytime, anywhere.

To find out how to get started,

select from the topics at the left.